170215 07:05:59 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data 170215 7:05:59 [Warning] 'THREAD_CONCURRENCY' is deprecated and will be removed in a future release. 170215 7:05:59 [Note] /usr/local/mysql/bin/mysqld (mysqld 5.5.48-log) starting as process 8091 ... /usr/local/mysql/bin/mysqld: File './mysql-bin.index' not found (Errcode: 13) 170215 7:05:59 [ERROR] Aborting
170215 07:05:59 mysqld_safe mysqld from pid file /usr/local/mysql/data/zbflash.pid ended ----------------------------------------------------------------------------------------------------------------------------------
我将所有日志文件 CP 到 /usr/local/mysql/data 日志又显示:
170215 07:24:20 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data 170215 7:24:20 [Warning] 'THREAD_CONCURRENCY' is deprecated and will be removed in a future release. 170215 7:24:20 [Note] /usr/local/mysql/bin/mysqld (mysqld 5.5.48-log) starting as process 10462 ... 170215 7:24:20 [Note] Plugin 'FEDERATED' is disabled. /usr/local/mysql/bin/mysqld: Table 'mysql.plugin' doesn't exist 170215 7:24:20 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it. 170215 7:24:20 InnoDB: The InnoDB memory heap is disabled 170215 7:24:20 InnoDB: Mutexes and rw_locks use GCC atomic builtins 170215 7:24:20 InnoDB: Compressed tables use zlib 1.2.3 170215 7:24:20 InnoDB: Initializing buffer pool, size = 128.0M 170215 7:24:20 InnoDB: Completed initialization of buffer pool 170215 7:24:20 InnoDB: highest supported file format is Barracuda. 170215 7:24:20 InnoDB: Waiting for the background threads to start 170215 7:24:21 InnoDB: 5.5.48 started; log sequence number 1595675 170215 7:24:21 [Note] Recovering after a crash using mysql-bin 170215 7:24:21 [Note] Starting crash recovery... 170215 7:24:21 [Note] Crash recovery finished. 170215 7:24:21 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306 170215 7:24:21 [Note] - '0.0.0.0' resolves to '0.0.0.0'; 170215 7:24:21 [Note] Server socket created on IP: '0.0.0.0'. 170215 7:24:21 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use 170215 7:24:21 [ERROR] Do you already have another mysqld server running on port: 3306 ? 170215 7:24:21 [ERROR] Aborting